import re
regex = re.compile(r"(?<![-\.\d])(?:0{0,2}?[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:0{0,2}?[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])", flags=re.MULTILINE)
test_str = ("str1 = 'Hello my name is Ben and my IP address is 256.0.0.0'\n"
"negative number is invalid: -127.2.1.2\n"
"valid: 001.001.001.001\n"
"str2 = 'Hello my name is Folks and my IP address is 1.2.3.4.5'\n"
"str3 = 'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")