use strict;
my $str = 'mujin:/a.mujin.json
mujin://b.mujin.json
/long/path/file.json
long/path/file.json
http://mujin.co.jp/path/file.json
http://mujin.co.jp/path/file.json?type=json
http://mujin.co.jp/path/file.json?type=json&scheme=mujin
http://mujin.co.jp/path/file.json?type=json#robot1
http://mujin.co.jp/path/file.json#robot1';
my $regex = qr/^(([^:\/?#]+):)?(\/\/([^\/?#]*))?([^?#]*)(\\?([^#]*))?(#(.*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}