$re = '/^(([^:\/?#]+):)?(\/\/([^\/?#]*))?([^?#]*)(\\\\?([^#]*))?(#(.*))?/m';
$str = 'mujin:/a.mujin.json
mujin://b.mujin.json
/long/path/file.json
long/path/file.json
http://mujin.co.jp/path/file.json
http://mujin.co.jp/path/file.json?type=json
http://mujin.co.jp/path/file.json?type=json&scheme=mujin
http://mujin.co.jp/path/file.json?type=json#robot1
http://mujin.co.jp/path/file.json#robot1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);