re = /^(([^:\/?#]+):)?(\/\/([^\/?#]*))?([^?#]*)(\\?([^#]*))?(#(.*))?/m
str = 'mujin:/a.mujin.json
mujin://b.mujin.json
/long/path/file.json
long/path/file.json
http://mujin.co.jp/path/file.json
http://mujin.co.jp/path/file.json?type=json
http://mujin.co.jp/path/file.json?type=json&scheme=mujin
http://mujin.co.jp/path/file.json?type=json#robot1
http://mujin.co.jp/path/file.json#robot1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end