$re = '/(.*)(running|stopped|starting)\.?$/';
$str = 'Some text that will always end in either running, stopped, starting.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);