re = /(.*)(running|stopped|starting)\.?$/
str = 'Some text that will always end in either running, stopped, starting.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end