const regex = /^(([a-zA-Z]:)|(\\{2}\w+\\[\w- ]+[$])|(\\{2}\w+))(\\[\w-. ]*)*(.xml|.XML)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([a-zA-Z]:)|(\\\\{2}\\w+\\\\[\\w- ]+[$])|(\\\\{2}\\w+))(\\\\[\\w-. ]*)*(.xml|.XML)$', 'gm')
const str = `c:\\path\\\\XX2 03-01-2017.xml
\\\\nas\\user\$\\XX2 03-01-2017.xml
\\\\network_shared\\.xml
\\\\a.XML`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}