$re = '/^(([a-zA-Z]:)|(\\\\{2}\w+\\\\[\w- ]+[$])|(\\\\{2}\w+))(\\\\[\w-. ]*)*(.xml|.XML)$/m';
$str = 'c:\\path\\\\XX2 03-01-2017.xml
\\\\nas\\user$\\XX2 03-01-2017.xml
\\\\network_shared\\.xml
\\\\a.XML';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);