package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(v__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*)__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*))(?:\.([A-Za-z]+))*\b`)
var str = `"123"+v__Shipment__shipment1.client.name.value+123
v__Shi11pment__shipment2.client.name
v__Shipment__shipment3.client.name
v__Ship_ment__shipment4.client.name
v__Shipment__shipment5.client.name
v__Shipment__shipment6.client.name
v__Shipment_shipment6.client.name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}