import Foundation
let pattern = #"\b(v__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*)__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*))(?:\.([A-Za-z]+))*\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"123"+v__Shipment__shipment1.client.name.value+123
v__Shi11pment__shipment2.client.name
v__Shipment__shipment3.client.name
v__Ship_ment__shipment4.client.name
v__Shipment__shipment5.client.name
v__Shipment__shipment6.client.name
v__Shipment_shipment6.client.name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)