const regex = /\b(v__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*)__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*))(?:\.([A-Za-z]+))*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(v__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*)__([A-Za-z0-9]+(?:_[A-Za-z0-9]+)*))(?:\\.([A-Za-z]+))*\\b', 'gm')
const str = `"123"+v__Shipment__shipment1.client.name.value+123
v__Shi11pment__shipment2.client.name
v__Shipment__shipment3.client.name
v__Ship_ment__shipment4.client.name
v__Shipment__shipment5.client.name
v__Shipment__shipment6.client.name
v__Shipment_shipment6.client.name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}