import re
regex = re.compile(r".*Voyage\:\\xa0{1}\s+([0-9]{4}[A-Z]{1}).*")
test_str = " \\nSEASPAN LONCOMILLA\\n\\r\\n Voyage:\\xa0 1396S\\r\\n \\n\\n\\r\\n 10-Apr\\r\\n ALGECIRAS\\r\\n \\n\\n\\r\\n 01-May\\r\\n KRIBI\\r\\n \\n\\n'"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")