using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^AB(\s(XX|YY))?\sCD(?!\1)(?1)?\sEF$";
string substitution = @"$1/";
string input = @"AB XX CD YY EF
AB YY CD XX EF
AB YY CD EF
AB CD YY EF
AB XX CD EF
AB CD XX EF
ABYY CD EF
AB CD XXEF
AB XX CD XX EF
AB XX YY CD EF";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}