$re = '/^AB(\s(XX|YY))?\sCD(?!\1)(?1)?\sEF$/m';
$str = 'AB XX CD YY EF
AB YY CD XX EF
AB YY CD EF
AB CD YY EF
AB XX CD EF
AB CD XX EF
ABYY CD EF
AB CD XXEF
AB XX CD XX EF
AB XX YY CD EF';
$subst = "$1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;