import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^AB(\\s(XX|YY))?\\sCD(?!\\1)(?1)?\\sEF$";
final String string = "AB XX CD YY EF\n"
+ "AB YY CD XX EF\n"
+ "AB YY CD EF\n"
+ "AB CD YY EF\n"
+ "AB XX CD EF\n"
+ "AB CD XX EF\n"
+ "ABYY CD EF\n"
+ "AB CD XXEF\n"
+ "AB XX CD XX EF\n"
+ "AB XX YY CD EF";
final String subst = "$1/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}