const regex = /(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?apps\\.apple\\.com(\\\/[a-zA-Z]{2})?\\\/(app|developer)\\\/.+', 'gmi')
const str = `https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489
http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489
https://apps.apple.com/app/id1610947489
apps.apple.com/app/id1610947489
https://apps.apple.com/us/developer/mobgames/id1608636552
https://apps.apple.com/us/devEloper/mobgames/id1608636552`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}