use strict;
my $str = 'https://apps.apple.com/us/app/poppy-playtime-chapter-1/id1610947489
http://apps.apple.com/SA/app/poppy-playtime-chapter-1/id1610947489
https://apps.apple.com/app/id1610947489
apps.apple.com/app/id1610947489
https://apps.apple.com/us/developer/mobgames/id1608636552
https://apps.apple.com/us/devEloper/mobgames/id1608636552';
my $regex = qr/(https?:\/\/)?apps\.apple\.com(\/[a-zA-Z]{2})?\/(app|developer)\/.+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}