#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)cite:[^@][A-Za-z0-9_-]+|\[\[cite:[^@][A-Za-z0-9_-]+\]\]"
Local $sString = "I want to recognize these as org-ref links " & @CRLF & _
"" & @CRLF & _
"[[cite:schuett-2018-schnet]]" & @CRLF & _
" cite:schuett-2018-schnet" & @CRLF & _
"" & @CRLF & _
"but not" & @CRLF & _
"" & @CRLF & _
" [cite:@schuett-2018-schnet]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")