package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\S+)\s+(\S+)\s+([^,]+),\s*([^:]+):\s*(.*)`)
var str = `a hier-steht-ein-Text und hier, kommt der Rest: 20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}