$re = '/^(\S+)\s+(\S+)\s+([^,]+),\s*([^:]+):\s*(.*)/';
$str = 'a hier-steht-ein-Text und hier, kommt der Rest: 20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);