re = /^(\S+)\s+(\S+)\s+([^,]+),\s*([^:]+):\s*(.*)/
str = 'a hier-steht-ein-Text und hier, kommt der Rest: 20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end