#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m){([a-z]+):([^\}]+)}"
Local $sString = "{id:\d+}" & @CRLF & _
"{page:[а-яё]+}"
Local $sSubst = "(?P<\1>\2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)