package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){([a-z]+):([^\}]+)}`)
var str = `{id:\d+}
{page:[а-яё]+}`
var substitution = "(?P<\1>\2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}