$re = '/{([a-z]+):([^\}]+)}/m';
$str = '{id:\\d+}
{page:[а-яё]+}';
$subst = "(?P<\1>\2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;