const regex = /^wp-content\/plugins\/(\w|\-)+\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^wp-content\\\/plugins\\\/(\\w|\\-)+\\\/', '')
const str = `wp-content/plugins/event-tickets/tests/wpunit/Tribe/Tickets/Attendance_RSVP_TotalsTest.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}