$re = '/\[\[[^]]+\]\]|\w+/m';
$str = '[[File:Euclid flowchart 1.png|vignette|[[Flowchart]] of an algorithm ([[Euclid\'s algorithm]]).]] blablablabla this " is \' \' (yes) not a link. This is a link [[Al-Andalus|andalou]] and this [[Babylone|Babyloniens]] is a link with a pipe in it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);