re = /\[\[[^]]+\]\]|\w+/m
str = '[[File:Euclid flowchart 1.png|vignette|[[Flowchart]] of an algorithm ([[Euclid\'s algorithm]]).]] blablablabla this " is \' \' (yes) not a link. This is a link [[Al-Andalus|andalou]] and this [[Babylone|Babyloniens]] is a link with a pipe in it.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end