import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?(?:1(\\s|-|\\.)?)?(\\d{3}\\1?\\d{3}\\1?\\d{4})$";
final String string = "1 555 222 5545\n"
+ "1-555-222-5562\n"
+ ".555-222-5562\n"
+ "5552226585\n"
+ "+1.888.558.5585\n"
+ "1 5552223334";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}