$re = '/^\+?(?:1(\s|-|\.)?)?(\d{3}\1?\d{3}\1?\d{4})$/m';
$str = '1 555 222 5545
1-555-222-5562
.555-222-5562
5552226585
+1.888.558.5585
1 5552223334';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);