import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\d月])([0-9]{1,2})(?=日)";
final String string = "4日 \n"
+ "12日\n"
+ "while ignoring the following strings completely.\n\n"
+ "3月01日\n"
+ "3月1日\n"
+ "3月31日";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}