const regex = /(?<![\d月])([0-9]{1,2})(?=日)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\d月])([0-9]{1,2})(?=日)', 'gu')
const str = `4日
12日
while ignoring the following strings completely.
3月01日
3月1日
3月31日`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}