$re = '/(?<![\d月])([0-9]{1,2})(?=日)/u';
$str = '4日
12日
while ignoring the following strings completely.
3月01日
3月1日
3月31日';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);