package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\\slash)+`)
var str = `lorem \lstinline{Foo\slash Bar\slash Foo} ipsum but \slash here is okay`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}