$re = '/(\\\\slash)+/m';
$str = 'lorem \\lstinline{Foo\\slash Bar\\slash Foo} ipsum but \\slash here is okay';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);