re = /(\\slash)+/m
str = 'lorem \\lstinline{Foo\\slash Bar\\slash Foo} ipsum but \\slash here is okay'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end