const regex = /^(^\s*\bput\s)((?!\sinto\s).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(^\\s*\\bput\\s)((?!\\sinto\\s).)*$', 'gm')
const str = `on mouseUp
put 10 into tFoo
put "added 10"
put tFoo + 5 into tBar
put "the answer is" & tBar
putMessage "the answer " & tbar & " was put into tBar"
putMessage "the above line should not be matched."
put tBar * 2 into tBar
put "tBar is" && tBar into field "answer"
put "'This line should be matched', he intoned."
put "This should be matched but having into here means this is not matched"
end mouseUp
on putMessage pMessage
if pMessage is not empty then
put "message:" & pMessage
end if
end putMessage
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}