use strict;
my $str = 'on mouseUp
put 10 into tFoo
put "added 10"
put tFoo + 5 into tBar
put "the answer is" & tBar
putMessage "the answer " & tbar & " was put into tBar"
putMessage "the above line should not be matched."
put tBar * 2 into tBar
put "tBar is" && tBar into field "answer"
put "\'This line should be matched\', he intoned."
put "This should be matched but having into here means this is not matched"
end mouseUp
on putMessage pMessage
if pMessage is not empty then
put "message:" & pMessage
end if
end putMessage
';
my $regex = qr/^(^\s*\bput\s)((?!\sinto\s).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}