import Foundation
let pattern = #"^(^\s*\bput\s)((?!\sinto\s).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
on mouseUp
put 10 into tFoo
put "added 10"
put tFoo + 5 into tBar
put "the answer is" & tBar
putMessage "the answer " & tbar & " was put into tBar"
putMessage "the above line should not be matched."
put tBar * 2 into tBar
put "tBar is" && tBar into field "answer"
put "'This line should be matched', he intoned."
put "This should be matched but having into here means this is not matched"
end mouseUp
on putMessage pMessage
if pMessage is not empty then
put "message:" & pMessage
end if
end putMessage
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)