using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|,)(?i:[а-яё]()|[^,])++(?!\2)";
string substitution = @"";
string input = @"42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you've done 4 times, pose 74, рисунок 12
привет, bobby, частота кадра 60fps, привет";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}