$re = '~(^|,)(?i:[а-яё]()|[^,])++(?!\2)~u';
$str = '42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you\'ve done 4 times, pose 74, рисунок 12
привет, bobby, частота кадра 60fps, привет';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;