import re
regex = re.compile(r"(^|,)(?i:[а-яё]()|[^,])++(?!\2)", flags=re.UNICODE)
test_str = ("42 year old, blonde, car, good green tree on field, правильное решение12, данных не больше 3, look what you've done 4 times, pose 74, рисунок 12\n"
"привет, bobby, частота кадра 60fps, привет")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)