using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:.*\n){5})((?:.*\n){5})";
string substitution = @"$1";
string input = @"1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}