re = /^((?:.*\n){5})((?:.*\n){5})/m
str = '1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result