#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(jsc)=.*?(;\s?|\s?) "
Local $sString = "JSC=wnCuqQ5vyFKcoeShsxZ7G2s8Bej4GCMI1YXd4PXf0fxPWLkrGCXnXr7EQK2eaaFXg_NwYDDdxEzSc2gkGZYZDhli4MzgNU2cCIW9KQ94BxbagB_Jq3ZCjp2BKpX3HCoTWvyMdSJaNGU40BjmYkybqGtXsiUXFJhFkb0KR_ykc_dEbcLMT2qIefBo9EZeMpXI2oSFl9JAi_lubjsTwSlo3kCGnf9qcfgYF_3LVJYpdsGkcNkkOaL4CGpHSZfCHtqQKzg1s3-6mfxtF-0RGD5nSI2AU6aNMgseEng_9fkGZ9_DZPnwo_8FRAQFoyapTsPy; __cfduid=d11f3a496a9bca3324d5a325ab57de95b1590591641; _csrf=dDJnl-L9LdJWLn2vcrlKDRau"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")