import re
regex = re.compile(r"(?i)(jsc)=.*?(;\s?|\s?) ", flags=re.MULTILINE)
test_str = "JSC=wnCuqQ5vyFKcoeShsxZ7G2s8Bej4GCMI1YXd4PXf0fxPWLkrGCXnXr7EQK2eaaFXg_NwYDDdxEzSc2gkGZYZDhli4MzgNU2cCIW9KQ94BxbagB_Jq3ZCjp2BKpX3HCoTWvyMdSJaNGU40BjmYkybqGtXsiUXFJhFkb0KR_ykc_dEbcLMT2qIefBo9EZeMpXI2oSFl9JAi_lubjsTwSlo3kCGnf9qcfgYF_3LVJYpdsGkcNkkOaL4CGpHSZfCHtqQKzg1s3-6mfxtF-0RGD5nSI2AU6aNMgseEng_9fkGZ9_DZPnwo_8FRAQFoyapTsPy; __cfduid=d11f3a496a9bca3324d5a325ab57de95b1590591641; _csrf=dDJnl-L9LdJWLn2vcrlKDRau"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")