import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(jsc)=.*?(;\\s?|\\s?) ";
final String string = "JSC=wnCuqQ5vyFKcoeShsxZ7G2s8Bej4GCMI1YXd4PXf0fxPWLkrGCXnXr7EQK2eaaFXg_NwYDDdxEzSc2gkGZYZDhli4MzgNU2cCIW9KQ94BxbagB_Jq3ZCjp2BKpX3HCoTWvyMdSJaNGU40BjmYkybqGtXsiUXFJhFkb0KR_ykc_dEbcLMT2qIefBo9EZeMpXI2oSFl9JAi_lubjsTwSlo3kCGnf9qcfgYF_3LVJYpdsGkcNkkOaL4CGpHSZfCHtqQKzg1s3-6mfxtF-0RGD5nSI2AU6aNMgseEng_9fkGZ9_DZPnwo_8FRAQFoyapTsPy; __cfduid=d11f3a496a9bca3324d5a325ab57de95b1590591641; _csrf=dDJnl-L9LdJWLn2vcrlKDRau";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}