use strict;
my $str = '12:04:19.85 14/09/2023 directory="E:\\data\\Test" ECHO is off.
Volume in drive E is Data Volume Serial Number is 7808-CA1B
Directory of E:\\data\\Test 13/09/2023 13:22
<DIR> XXX\\xxxx . 13/09/2023 13:22 <DIR> xxx\\xxx .. 12/09/2023 09:31 95 xxx\\xxx dir_details.bat 13/09/2023 13:41 171 xxx\\xxx dir_details_copy.bat 07/09/2023 13:26 0 xxx\\xxx edsadsad.txt 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkdl.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewew.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewewdsads.zip 6 File(s) 332 bytes 2 Dir(s) 20718067712 bytes free';
my $regex = qr/(?<filename>OU_\w*\.\w*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}