# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<filename>OU_\w*\.\w*)"
test_str = ("12:04:19.85 14/09/2023 directory=\"E:\\data\\Test\" ECHO is off.\n\n"
"Volume in drive E is Data Volume Serial Number is 7808-CA1B\n\n"
"Directory of E:\\data\\Test 13/09/2023 13:22\n\n"
"<DIR> XXX\\xxxx . 13/09/2023 13:22 <DIR> xxx\\xxx .. 12/09/2023 09:31 95 xxx\\xxx dir_details.bat 13/09/2023 13:41 171 xxx\\xxx dir_details_copy.bat 07/09/2023 13:26 0 xxx\\xxx edsadsad.txt 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkdl.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewew.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewewdsads.zip 6 File(s) 332 bytes 2 Dir(s) 20718067712 bytes free")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.