re = /(?<filename>OU_\w*\.\w*)/m
str = '12:04:19.85 14/09/2023 directory="E:\\data\\Test" ECHO is off.
Volume in drive E is Data Volume Serial Number is 7808-CA1B
Directory of E:\\data\\Test 13/09/2023 13:22
<DIR> XXX\\xxxx . 13/09/2023 13:22 <DIR> xxx\\xxx .. 12/09/2023 09:31 95 xxx\\xxx dir_details.bat 13/09/2023 13:41 171 xxx\\xxx dir_details_copy.bat 07/09/2023 13:26 0 xxx\\xxx edsadsad.txt 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkdl.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewew.zip 07/09/2023 13:26 22 xxx\\xxx OU_kljdajdklsajkewewdsads.zip 6 File(s) 332 bytes 2 Dir(s) 20718067712 bytes free'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end