import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\)[^\\\\]+sav";
final String string = "C:\\Users\\\\...\\\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\\\WinterLo-20180729-043047-34-SystemNormal\\\\WinterLo-20180729-043047-34-SystemNormal.sav";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}